読者です 読者をやめる 読者になる 読者になる

Pythonのバージョンをあげた時に、easy_installも新しいPython用にする

MacのPython2.5を2.6にアップグレードして
easy_installでMercurialSphinxを入れようとしたけれど
Python2.5のeasy_installが起動してしまったので
以下、やることのメモです。

ez_setup.pyをダウンロードする。

$ python ez_setup.py

#既存のeasy_installをリネーム
$ sudo mv /usr/bin/easy_install /usr/bin/easy_install.old

#シンボリックリンクの作り直す
$ sudo ln -s /Library/Frameworks/Python.framework/Versions/2.6/bin/easy_install /usr/bin/easy_install